IndieDroid Nova no boot from emmc or tf-card (sdcard)

please help or advice, many THX
received my new IndieDroid Nova (16GB RAM / 64GB emmc) but so far I’m unable to boot the board.

I tried so far:

  • two different power supply each rated with at least 3A
  • boot attempt from emmc only
  • boot attempt from SD only

I used these images :

  • Armbian_23.05.0-Indiedroid-nova_jammy_legacy_5.10.110-BT-GPUAccel
  • Armbian_23.05.0-Indiedroid-nova_jammy_legacy_5.10.110-BT-GPUAccel-AutoExpand-SD-EMMC-DualBoot
  • Indiedroid_23.05.0-trunk_Indiedroid-nova_jammy_indiedroid_5.10.110_cinnamon_desktop

but so far no success.

Please is there any indication that the SBC detected the emmc or SD card and is booting the board ?
The board I have immediately after power on switches the RED LED ON, same is the green LED on the Ge network adapter. Both LEDs stay ON without any flashing or kind of heart-beat .

The HDMI output is just black - no signal.
Please advice.
Is there active UART serial port during boot ? If so pls, how to connect (PINs, speed, etc.)
Or any other procedure I can try.
Thank you very much in advance.

Have you checked this out yet?

Same situation, used different cables, last cable used it was able to detect by the monitor (signal).But remained blank, no indication of booting. I already checked the troubleshooting guide but still no avail.

Make sure the display cable is plugged in fully before applying power to the unit. The display may not be initialized if it isn’t detected at boot time.

Another thing to try is a USB-C to HDMI cable along with the Android tablet-style image. The Android image is known to work with both USB-C and microHDMI.

In answer to your previous question, there is a serial port below the USB ports that is active from the point where power is applied to the unit. This is the recommended cable for this: Indiedroid Nova UART Module and Cable — ameriDroid