QEMU/KVM On Ameridroid Nova?

QEMU/KVM On Ameridroid Nova?

I have KVM VMs running on Ameridroid Nova, but I can’t get graphical modes in the VMs to work, only serial consoles. Any one run into this issue? The aarch64 variant of QEMU/KVM fails to initialize graphic modes?

We were under the impression that VMs required virtualization features built into the processor. As far as we know, ARM SoCs don’t have virtualization support, including the RK3588S used in the Nova.

But perhaps KVM VMs don’t require this feature. Hopefully someone more experienced with KVM VMs can add some more useful information.

Doing KVM/Libvirt is simple, please follow my guide.

This youtube video is for the OrangePi 5, but to show you that these RockChip can easily run it Libvirtd.

Yeah, I have VMs running, just have not found the right configuration to get the GUI working. As long as I stay with the default output device, i.e. a simple console, works. So any VM running as a text console, server for example I have working. But if I want to run any graphical mode, say for Gnome, for example, having issues.

Following the steps in the link… I still get “Guest has not initialized the display (yet).” error. This appears to be catch-22 type of bug with how UEFI boot handles the display versus how the installer engages with the display it finds. If the ‘Console 1’ device exists, the installer falls back to that display device, if the ‘Console 1’ device is removed or not configured, the installer runs (apparently) but no output results on VM screen.

I have tried just about every combination possible, video as VGA, graphic as VNC, etc., etc. Not yet found a combination of settings for video/graphic devices that work.

Do you have errors? Anything that would help me, help you.

So let me do a new video, because yes when you start a new virt, you get that message for a bit, like 10 to 30 mins, but that the ISO booting up, once it’s built, it comes up a lot quicker.

Just so I understand, how do you configure the OS in the VM, if you have no display? Sorry, am I missing something? Any ISO I use for a VM OS load via serial/console takes less than a minute to display the installer. So why would graphic mode take 10 to 30 minutes?

@terrorpup You ever update or create the new video?